Application Performance Issue
Incident Report for RevolutionEHR
Resolved
All systems continue to show that performance is normal and stable
Posted Sep 29, 2022 - 08:17 CDT
Monitoring
The scaling efforts around the detected firewall issue has significantly decreased the latency impacting some customers. Our engineers will continue to monitor at this time to ensure a complete resolution
Posted Sep 27, 2022 - 14:42 CDT
Update
We have identified a traffic saturation issue with our frontend firewalls and are in the process of scaling our resources to accommodate the increased load. We continue to monitor a number of provider outages regionally that may be affecting some customers performance in RevolutionEHR independent of this issue.
Posted Sep 27, 2022 - 12:46 CDT
Identified
Engineering has continued to monitor the connectivity and packet loss issue being noted by a Level 3 network provider feeding into AWS. Degraded performance is still being reported but it has showed some improvement. Unfortunately, this may continue to impact some customers. We will continue to post updates as the become available
Posted Sep 27, 2022 - 08:05 CDT
Update
Engineering has discovered that there is a large network provider feeding into our AWS data center that is having issues that could be causing some clients to see intermittent lag and connection issues. We will continue to monitor the status, and will continue to investigate any other potential causes, although at this time the network provider is the most likely cause.
Posted Sep 26, 2022 - 17:21 CDT
Update
We are continuing to investigate concerns around performance. Unfortunately at this time, reports are inconsistent and not widespread. There is no evidence of any issues directly on the servers. Our engineers are looking at any potential causes, including, but not limited to, ISPs, Data Center and Internet Backbones (principal data routes)
Posted Sep 26, 2022 - 16:12 CDT
Investigating
We are aware of an issue that is impacting application performance. Our engineers are currently investigating the cause.

More information will be posted as it becomes available.
Posted Sep 26, 2022 - 10:55 CDT
This incident affected: RevolutionEHR United States.