Pulse is not reporting data beyond 7/21/2022
Incident Report for RevolutionEHR
Resolved
This incident has been resolved.
Posted Jul 28, 2022 - 15:51 CDT
Investigating
We are currently investigating an issue that has caused Pulse in the US to stop reporting data. The appear to impact all dates from 7/21/2022
Posted Jul 25, 2022 - 09:59 CDT
This incident affected: RevolutionEHR United States.