Unable to access certain Modules
Incident Report for RevolutionEHR
Resolved
This incident has been resolved
Posted Feb 06, 2023 - 16:43 CST
Identified
A potential cause has been identified and engineering is working to implement a fix at this time
Posted Feb 06, 2023 - 15:23 CST
Investigating
We are receiving reports of customers unable to access the Schedule and some areas in the Administration Module. Other areas may be impacted as well. Our engineers have been made aware and are actively looking into it. Additional updates will be posted here as they become available
Posted Feb 06, 2023 - 15:15 CST
This incident affected: RevolutionEHR United States.