Bluefin integration is down
Incident Report for RevolutionEHR
Resolved
This incident has been resolved.
Posted Nov 20, 2020 - 09:45 CST
Investigating
We are receiving reports from customers that the Bluefin integration for credit cards is not working. We are investigating this issue and will post updates as they become available
Posted Nov 20, 2020 - 09:14 CST
This incident affected: Integrated Partners.