Performance issues affecting US customers
Incident Report for RevolutionEHR
Resolved
This incident has been resolved.
Posted Nov 20, 2020 - 09:13 CST
Update
We are continuing to monitor for any further issues.
Posted Nov 16, 2020 - 17:25 CST
Update
We are continuing to monitor for any further issues.
Posted Nov 16, 2020 - 16:58 CST
Monitoring
A fix has been implemented and we are monitoring at this time. We will provide details once it has been establish the the fix is stable
Posted Nov 16, 2020 - 16:58 CST
Identified
The engineering team believes they have identified the cause of the issue, they are confirming the information and then will work toward a resolution
Posted Nov 16, 2020 - 15:45 CST
Update
For many customers access to RevolutionEHR is completely down. All resources are continuing to work this issue
Posted Nov 16, 2020 - 14:47 CST
Investigating
We are aware of performance issues effecting all US customers and are investigating the cause. We will post an update as soon an information becomes available.
Posted Nov 16, 2020 - 14:15 CST
This incident affected: RevolutionEHR United States.