Application Performance Issue
Incident Report for RevolutionEHR
Resolved
This incident has been resolved.
Posted Sep 17, 2020 - 11:05 CDT
Investigating
We are aware of an issue that is impacting application performance for some of our customers. Our engineers are currently investigating the cause.

More information will be posted as it becomes available.
Posted Sep 17, 2020 - 09:51 CDT
This incident affected: RevolutionEHR United States.