RevEngage is currently unavailable

Incident Report for RevolutionEHR

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 10:45 CST

Monitoring

CloudFlare has reported that their outage has been resolved
Posted Nov 18, 2025 - 09:00 CST

Identified

An outage at CloudFlare is impacting several systems like ChatGPT and X. Doctible, which powers RevEngage, is also being impacted by the CloudFlare outage. We will continue to monitor the information being posted by CloudFlare and provide any updates as they become available
Posted Nov 18, 2025 - 08:23 CST
This incident affected: Integrated Partners.