Trouble Loading RevolutionEHR
Incident Report for RevolutionEHR
Resolved
This incident has been resolved.
Posted Jun 29, 2022 - 07:29 CDT
Identified
If you are having trouble loading the RevolutionEHR application, please follow these troubleshooting steps:
1. If you use a bookmark to access the application, please ensure you are using the current URL and update your bookmarks if necessary: https://revolutionehr.com/static/
2. If you are still unable to load the application using the URL above, please clear your cache or try another browser to verify access to the application.
3. If you are still unable to load the application, or all users in your office are affected, please consider restarting your internet router.
Posted Jun 25, 2022 - 11:56 CDT
This incident affected: RevolutionEHR United States.