Attention RevDirect Users Only: RevDirect partner is currently unable to add new RevDirect addresses
Incident Report for RevolutionEHR
Resolved
This incident has been resolved.
Posted Sep 18, 2023 - 11:14 CDT
Update
Secure Exchange Solutions is still actively working to resolve this issue, we do not have any new updates from them at this time, but will post information as it becomes available
Posted Jul 27, 2023 - 16:12 CDT
Investigating
RevolutionEHR users are receiving an error when attempting to create new RevDirect addresses. We are currently working with Secure Exchange Solutions to resolve the issue and will post any updates as they become available at the end.
Posted Jul 24, 2023 - 10:43 CDT
This incident affected: Integrated Partners.