Reporting Dely

Incident Report for RevolutionEHR

Resolved

This incident has been resolved.
Posted Feb 04, 2025 - 17:16 CST

Investigating

There is currently a delay of approximately 20 minutes as it relates to reports also when adding inventory. Any new data entered can take up to 20 minutes to appear in an associated reports. For example, when receiving a payment or adding a new inventory item it may take up to 20 minutes appear. This does not impact claim status updates.
Posted Feb 04, 2025 - 10:59 CST
This incident affected: RevolutionEHR United States.