Errors Reported When Accessing Multiple RevolutionEHR Accounts

Incident Report for RevolutionEHR

Resolved

This incident has been resolved.
Posted Sep 04, 2025 - 12:28 CDT

Identified

We have identified an issue affecting billers and other users with access to multiple RevolutionEHR accounts, where functionality challenges arise when switching between accounts.

Our engineering team has developed a solution, and we are scheduled to deploy a fix tonight at 9:00 PM PST. This update will not cause any system downtime; however, active users will be logged out and prompted to log in again.

To avoid issues until the fix is implemented, we recommend that users switching between RevolutionEHR accounts log out of RevolutionEHR, close their browser, reopen the browser, and then navigate to revolutionehr.com.

Thank you for your patience and understanding. If you have any questions, please contact our support team.
Posted Sep 03, 2025 - 14:04 CDT
This incident affected: RevolutionEHR United States.