Reporting Delay

Incident Report for RevolutionEHR

Resolved

This incident has been resolved.
Posted Feb 06, 2025 - 16:48 CST

Investigating

There is currently a delay of approximately 10 minutes as it relates to reports also when adding inventory. Any new data entered can take up to 10 minutes to appear in an associated reports. For example, when receiving a payment or adding a new inventory item it may take up to 10 minutes appear. This does not impact claim status updates.
Posted Feb 06, 2025 - 15:24 CST
This incident affected: RevolutionEHR United States.