Live Chat is currently unavailable
Incident Report for RevolutionEHR
Resolved
This issue with Live Chat has been resolved. If you are seeing a red indicator you may need to refresh your browser.
Posted May 15, 2020 - 11:49 CDT
Update
We are continuing to work on a fix for this issue.
Posted May 15, 2020 - 11:48 CDT
Identified
Currently the Live Chat feature located within the RevolutionEHR software is unavailable. We are working with the third party that provides our Live Chat services to restore this as quickly as possible. In the interim please contact support at 877-738-3471 ext 2 if you need assistance. We will post updates as they become available
Posted May 15, 2020 - 08:54 CDT
This incident affected: RevolutionEHR United States and RevolutionEHR Canada.