ClinicAid Claim Submission Issue

Incident Report for RevolutionEHR

Monitoring

ClinicAid has rolled back changes associated with this issue, and offices may now resume submitting claims. Our teams will continue working together to identify and implement a permanent solution while monitoring the integration.
Posted Sep 22, 2026 - 13:08 CDT

Investigating

We are investigating an issue affecting claim submissions to ClinicAid. Claims are currently not being accepted, and offices may receive the following error:

“Error processing provider: business_arrangement=[must be a 7 digit number]”

Our team is working with ClinicAid to identify the cause and determine next steps. We will provide additional updates as more information becomes available.
Posted Sep 22, 2026 - 11:23 CDT
This incident affects: RevolutionEHR Canada.