Application Performance Issue

Incident Report for RevolutionEHR

Resolved

This incident has been resolved.
Posted 2 years ago. Jun 22, 2023 - 09:03 CDT

Update

We continue to make iterative improvements to protect system stability and saw significant improvements at the end of last week. We will continue to monitor the system at a very high level while additional improvements are added. We will be providing more detailed information regarding the recent issues.
Posted 2 years ago. May 15, 2023 - 08:26 CDT

Update

We are continuing to monitor for any further issues.
Posted 2 years ago. May 08, 2023 - 14:25 CDT

Update

We are continuing to monitor for any further issues.
Posted 2 years ago. May 08, 2023 - 12:42 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 2 years ago. May 08, 2023 - 12:26 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted 2 years ago. May 08, 2023 - 12:12 CDT

Investigating

We are aware of an issue that is impacting application performance. Our engineers are currently investigating the cause.

More information will be posted as it becomes available.
Posted 2 years ago. May 08, 2023 - 12:10 CDT
This incident affected: RevolutionEHR United States.