RevClear Auto-Posting - Pending Payments And Tasks Not Generating

Incident Report for RevolutionEHR

Resolved

The processing delay has been resolved and normal operations have resumed. Any outstanding items are being handled automatically.

If your office posted payments manually during the delay, you may see a pending payment. Please review and remove it if the payment has already been applied. In some cases, you may instead receive a notification indicating the invoices were previously addressed.
Posted Feb 24, 2026 - 15:56 CST

Investigating

We are currently investigating an issue with RevClear Auto-Posting. Some payments downloaded from TriZetto on or after February 19, 2026 may not have automatically posted to Accounting > Payments > Pending Payment or created the related tasks in RevolutionEHR.

Our team is actively reviewing the issue and will provide updates as they become available.
Posted Feb 23, 2026 - 13:43 CST
This incident affected: Integrated Partners.