TriZetto Connectivity Issue

Incident Report for RevolutionEHR

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 13:16 CST

Investigating

We are aware of an issue affecting TriZetto SFTP login functionality, which may impact users’ ability to submit claims and statements from RevolutionEHR to Trizetto. TriZetto is currently investigating the issue. We will provide updates as more information becomes available.
Posted Dec 04, 2025 - 08:28 CST
This incident affected: RevolutionEHR United States.