RevEngage Unable To Send Outbound Emails

Incident Report for RevolutionEHR

Resolved

This incident has been resolved.
Posted Dec 15, 2025 - 16:21 CST

Identified

RevEngage is currently experiencing issues that may affect outbound messaging for practices utilizing the service. You can follow live updates here:

🔗 https://doctible.statuspage.io/incidents/n9ghfqpx296r

RevolutionEHR remains fully operational; only RevEngage is impacted. We’re monitoring the situation closely and will provide updates as they become available.
Posted Dec 15, 2025 - 12:40 CST
This incident affected: Integrated Partners.