Unable to open Invoices in Canada

Incident Report for RevolutionEHR

Resolved

This incident has been resolved.
Posted Mar 07, 2026 - 11:45 CST

Monitoring

The system has been resolved and invoices are now available, we will continue to monitor the system
Posted Mar 07, 2026 - 09:27 CST

Update

The Canada environment is currently unavailable as the resolution to fix the invoice issue is being patched out. The system will be back up very shortly
Posted Mar 07, 2026 - 09:23 CST

Investigating

We are investigating an issue in Canada that is creating an error message when trying to open an invoice
Posted Mar 07, 2026 - 08:52 CST
This incident affected: RevolutionEHR Canada.