RevCheck Status Update

Incident Report for RevolutionEHR

Resolved

This incident has been resolved.
Posted Aug 05, 2026 - 08:52 CDT

Investigating

We are currently experiencing an issue with RevCheck that began at approximately 7:00 AM ET today (8/4).

Most appointments scheduled for today were successfully processed before the issue began, so those eligibility verification results are still available. However, no new eligibility verification results are currently being written back into RevolutionEHR.

The ABB Verify team is actively working to restore the service. We are monitoring the situation closely and will provide updates as they become available.
Posted Aug 04, 2026 - 12:25 CDT
This incident affected: Integrated Partners.