Slow response time
Incident Report for RevolutionEHR
Resolved
This incident has been resolved.
Posted Jun 30, 2023 - 16:37 CDT
Monitoring
Stability has been restored and we will continue to monitor
Posted Jun 30, 2023 - 10:40 CDT
Investigating
We are seeing slower response times in RevolutionEHR. The team is working to restore normal response times
Posted Jun 30, 2023 - 10:33 CDT
This incident affected: RevolutionEHR United States.