Issue Impacting TriZetto Login Functionality

Incident Report for RevolutionEHR

Resolved

This incident has been resolved.
Posted Jan 28, 2026 - 14:15 CST

Investigating

We are aware of an issue affecting TriZetto login functionality, which may impact user's ability to submit claims and statements. TriZetto is currently investigating the issue.
Posted Jan 28, 2026 - 12:04 CST
This incident affected: Integrated Partners.