Lag time with Trizetto claims
Incident Report for RevolutionEHR
Update
Update provided by Trizetto: On 3/16, we had planned to update our servers (Serv-U) which would improve the system sluggishness, but the deployment was rolled back. April 20th is the rescheduled date to update our servers along with updating our security encryption
Posted Apr 03, 2024 - 12:12 CDT
Update
We have received notification from Trizetto that the update did not occur, we will continue to post updates as they become available"
Posted Mar 18, 2024 - 08:40 CDT
Update
Trizetto is planning on doing an update this weekend which should resolve this lagging issue once completed.
Posted Mar 15, 2024 - 16:10 CDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 14, 2024 - 09:08 CDT
Identified
Trizetto has notified us that they are experiencing high traffic on their websites which is causing slowness on their servers. Due to the slowness of TriZetto’s servers clients can experience slowness when sending claims or statements from RevolutionEHR to Trizetto. Although Trizetto is working to resolve this issue an eta is not known.
Posted Mar 14, 2024 - 09:07 CDT
This incident affects: Integrated Partners.