Reports of customers unable to submit claims to Trizetto

Incident Report for RevolutionEHR

Resolved

We have received notification from Trizetto that this issue has been resolved.
Posted Jan 16, 2026 - 16:27 CST

Investigating

We are receiving reports that customers are receiving an error message that we are unable to connect to TriZetto SFTP server. Early indicators are showing this may be an issue at Trizetto. We are contacting Trizetto for an update and will provide more information as it becomes available.
Posted Jan 16, 2026 - 13:31 CST
This incident affected: Integrated Partners.