RXNT Reporting Login and Performance Issues

Incident Report for RevolutionEHR

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 12:34 CDT

Investigating

RXNT has informed us that some users are experiencing disruptions impacting their eRx services. Specifically, users may encounter significant slowness when attempting to access these systems, with applications either failing to load or taking several minutes to open. RXNT is currently investigating the issue and working toward a resolution.
Posted Apr 08, 2026 - 10:33 CDT
This incident affected: Integrated Partners.