Delay in Reports and Claim Status
Incident Report for RevolutionEHR
Resolved
This incident has been resolved.
Posted May 25, 2023 - 17:02 CDT
Monitoring
The reports are no longer experiencing a delay, we will continue to monitor
Posted May 25, 2023 - 13:06 CDT
Investigating
There is currently a delay of approximately 10 to 15 minutes as it relates to reports which also includes claim status. Any new data entered can take up to 10 to 15 minutes to appear in an associated report and any change in claim status will also be delayed. For example, authorizing an invoice may take up to 15 minutes for the claim to appear in the Claims to Submit list.
Posted May 25, 2023 - 10:54 CDT
This incident affected: RevolutionEHR United States.