Customer Support currently unavailable
Incident Report for RevolutionEHR
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 11:16 CDT
Identified
We are currently experiencing technical issues that are preventing our Customer Support team from accessing phones, emails and live chats. We appologize for the inconvenience. Our IT department is working to resolve this issue as quickly as possible. This is an internal issue and does not impact any customer's ability to access and use RevolutionEHR.
Posted Mar 26, 2024 - 08:24 CDT
This incident affected: RevolutionEHR United States and RevolutionEHR Canada.