Clinic Aid 403 Error During Claim Submission

Incident Report for RevolutionEHR

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 12:49 CDT

Monitoring

We are aware of an issue affecting some offices when submitting claims to ClinicAid. Impacted users may receive a 403 error during claim submission.

ClinicAid has advised that recent security updates on their end are causing this error for some users. Their development team is actively investigating the issue and working toward a resolution.

We will continue to monitor the situation and share additional updates as they become available from ClinicAid.
Posted Jul 08, 2026 - 09:37 CDT
This incident affected: RevolutionEHR Canada.