TriZetto Connectivity Issue

Incident Report for RevolutionEHR

Resolved

This incident has been resolved.
Posted Nov 11, 2025 - 12:39 CST

Investigating

TriZetto is currently experiencing issues that are preventing users from logging in. Their team is actively investigating and working to resolve the problem.

As a result, RevolutionEHR users may encounter an “Unable to connect to TriZetto” error message when attempting to submit claims or send patient statements.

We will provide updates as soon as more information becomes available.
Posted Nov 10, 2025 - 13:47 CST
This incident affected: Integrated Partners.