Crowdstrike issues are not currently impacting RevolutionEHR
Incident Report for RevolutionEHR
Resolved
RevolutionEHR remained impact free throughout the day
Posted Jul 19, 2024 - 16:16 CDT
Monitoring
We are actively monitoring the current outages affecting Intermedia services due to a recent CrowdStrike update. This issue has disrupted many businesses worldwide, including airlines, banks and technology companies as well as Microsoft Windows system that support Intermedia's services.

RevolutionEHR is not impacted by any of these current issues. However we will continue to actively monitor the situation and post any updates should any changes arise.
Posted Jul 19, 2024 - 08:30 CDT
This incident affected: RevolutionEHR United States, RevolutionEHR Canada, and Integrated Partners.