Error: Unable to Connect to Trizetto

Incident Report for RevolutionEHR

Resolved

Our development team in conjunction with Trizetto identified the issue that sometimes prevents connection to Trizetto when practice login information is correct while submitting claims. A solution has been rolled out to resolve this issue.

Please contact RevolutionEHR Customer Support if you should get an Unable to Connect to Trizetto error message when submitting claims.
Posted Feb 20, 2025 - 16:03 CST

Update

Trizetto is continuing to investigate this issue
Posted Jan 20, 2025 - 09:25 CST

Investigating

We have received reports from several offices regarding the persistence of the "Unable to connect" error message. Our team has reached out to Trizetto for insights into this issue, and our RevolutionEHR development team is actively investigating further.

When the error is received, RevolutionEHR is attempting to connect with Trizetto using the provided login information, but access is not being granted.

While clearing your browser history has previously resolved this issue, we recognize that it is only a temporary solution. We are working diligently to find a long-term fix and will keep you updated as we learn more.
Posted Jan 17, 2025 - 12:28 CST
This incident affected: Integrated Partners.