RevolutionEHR is currently down, we are actively investigating the issue
Incident Report for RevolutionEHR
Resolved
This incident has been resolved.
Posted Jan 06, 2022 - 20:51 CST
Update
Please note this is unrelated to the current maintenance being done on the Canada Sandbox
Posted Jan 06, 2022 - 20:18 CST
Update
We are continuing to investigate this issue.
Posted Jan 06, 2022 - 20:11 CST
Investigating
We are currently investigating this issue.
Posted Jan 06, 2022 - 20:11 CST
This incident affected: RevolutionEHR United States.