RevImaging Image Display Issues

Incident Report for RevolutionEHR

Resolved

This issue has been resolved. If you were impacted you will need to log out/in to see the update
Posted Jul 31, 2026 - 12:02 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 31, 2026 - 10:52 CDT

Investigating

We are currently investigating an issue that is blocking RevImaging from displaying the thumbnails for files uploaded after 2021. In some instances clicking on the thumbnail will display the image above but not for all. We will continue to provide updates as they become available
Posted Jul 31, 2026 - 10:43 CDT
This incident affected: RevolutionEHR United States and RevolutionEHR Canada.