Error when accessing RevolutionEHR in Canada
Incident Report for RevolutionEHR
Resolved
Issue has been identified and resolved. Users can access without issue. Thanks for your patience.
Posted Apr 02, 2021 - 13:59 CDT
Investigating
We are currently investigating an issue when trying to access RevolutionEHR in Canada. You may see an error or delayed response. As soon as we have more information to share, we will post an update. Thank you.
Posted Apr 02, 2021 - 13:45 CDT
This incident affected: RevolutionEHR Canada.