Printing and upload Error – Troubleshooting Steps

Incident Report for RevolutionEHR

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 09:17 CDT

Investigating

We are currently receiving reports that some offices are experiencing errors when attempting to print or uploading files. If you're encountering this issue, please follow the steps below:

Ensure your web browser is up to date.

Clear your browser cache.

Allow pop-ups for Revolution in your browser settings.

These steps often resolve the issue. If the problem persists after trying the above, please reach out to our support team for further assistance.

Thank you for your patience!
Posted Aug 27, 2025 - 08:59 CDT
This incident affected: RevolutionEHR United States and RevolutionEHR Canada.